collapse


* User Info

 
 
Welcome, Guest. Please login or register.
Did you miss your activation email?

* Who's Online

beavBCGQC

Dot Guests: 113 | Dot Users
Dot Hidden: 0

* Board Stats

  • stats Total Members: 12956
  • stats Total Posts: 129928
  • stats Total Topics: 18173
  • stats Total Categories: 5
  • stats Total Boards: 48
  • stats Most Online: 814

* Advertisers

Gear Pan
The lil Gold Spinner
BC GOLD
The lil Gold Spinner
The Pocket Sluice

Author Topic: Any one have problems trying to stake ground??  (Read 914 times)

0 Members and 1 Guest are viewing this topic.

Offline nite hawk

  • PPT Invited
  • *****
  • Posts: 492
  • Kudos: 10
Any one have problems trying to stake ground??
« on: July 13, 2018, 04:36:07 PM »

Howdy!
 I have been away from placer mining for quite a while, and things came together to get back into mining.
I re-newed my BCEID and my FMC at the government office and tried to stake a piece of ground that I want.
 I was having problems with some of the paperwork and the worker there, ( who was polite , and as helpful as she could be ) told me straight out that none of the workers there knew much about MTO, and she gave me a couple of phone numbers for MTO.. Supposed to be a direct line to MTO..
Well I tried the 2 different numbers that she gave me, and both times I got a recording “ leave your number and we will get back to you ASAP”
 Ummmm this is the government office and there is no number on the phone I am using, and I need help NOW not “when ever”.
 I tried to stake at the government office and the “re-captcha” kept spinning me in circles, over and over and over again, and then it would say “your “re-captcha” has expired.”
 I tried over and over to get through or around the “re-captcha”  it kept saying it had expired or would just keep putting more pictures up to choose from..
 I totally backed out and re-selected the ground that I wanted and I tried to get passed the “re-captcha”  I tried backing out and starting over with no luck.
I finally gave up and left when there was only a maybe 15 minutes before the office closing.
When I got home I tried it again and there was no problem getting passed the “re-captcha”. I hit the payment method and put my info in and hit finish and it came back “payment declined”.
I rechecked the card info and everything was in order and tried again.. Again –payment declined. I tried this several times and finally called the bank.
The gal told me that everything was fine on their end and with the account., so I sent an email off to MTO..
I was informed that MTO did not take visa debit but that On Thursday, Visa Debit would be accepted by MTO..
On Thursday I tried again, and it again said “payment declined” I again re-contacted MTO, and they said it would come online at 2:00 PM…
So at 10:00PM I tried again, again got the message “payment declined”.
I again e-mailed them and I told them that I was using visa debit and it was not working on MTO but it was supposed to. I also copied the transaction and emailed it to them
 I received a reply from MTO this morning saying - “Debit didn’t work on MTO, but visa debit would”.
I was told to “use a credit card or visa debit, or go to “Front Counter B.C” or the government agent”.
I don’t have a stack of  different credit cards and have used the visa debit with no problem only a few days prior to this mess without any problems, and there is NO front counter in Horsefly or Williams Lake, the nearest being in I think Quesnel, and I have already been to the government agent in W.L. and had no luck there..
 Once again I emailed MTO saying that I was using visa debit and there was NO front counter here, and I had been to the government agent.
They say it is updated to receive visa debit, but it is not working.The government agents computer “re-captcha”  is not going to allow me to get in to stake.
My frustration level after a week of “chasing my tail” is starting to get rather “raw”
I do work during the day, so cant just get on the phone when ever the idea comes to mind..
I got another e-mail saying that maybe they could phone me and tell me why the debit visa wasn’t working..
Then the last email I got was saying that –“well maybe the debit visa issue on MTO would be working by Monday”.. Like I said I don’t have a stack of credit cards, so I can’t just grab another one and try that one, and am getting frustrated. I will be totally “unhappy” if the ground I want is gone by Monday. I do have the copy of the attempt at staking and the “payment declined” page. But I don’t think that has any weight in a dispute..
Anyone have much trouble staking??

Offline chrisg

  • Full Member
  • ****
  • Posts: 107
  • Kudos: 2
Re: Any one have problems trying to stake ground??
« Reply #1 on: July 13, 2018, 08:52:01 PM »
You have my sympathies there, you have more patience than me, I can't really provide too much help, however, working for a company that has software that needs to be configured with credit card processors, the answers you were getting, seems to be like you were getting a new integration with a credit card and well sometimes the configuration needs bugs sorted out.  Breath deeply before punching!  I do wish you the best of luck and never give up, when you get this stake it will feel so sweet.  Cheers Chris

Offline CMMC

  • Full Member
  • ****
  • Posts: 77
  • Province/State: Delta, British Columbia
  • Country: ca
  • Kudos: 22
Re: Any one have problems trying to stake ground??
« Reply #2 on: July 13, 2018, 09:29:29 PM »
Go buy a prepaid Vanilla Visa Card from 7-11 or from another location. They work 100% on the MTO site when purchasing a claim.

Offline nite hawk

  • PPT Invited
  • *****
  • Posts: 492
  • Kudos: 10
Re: Any one have problems trying to stake ground??
« Reply #3 on: July 13, 2018, 09:44:50 PM »
CMMC
Have you personally used a vanilla card?

Offline CMMC

  • Full Member
  • ****
  • Posts: 77
  • Province/State: Delta, British Columbia
  • Country: ca
  • Kudos: 22
Re: Any one have problems trying to stake ground??
« Reply #4 on: July 13, 2018, 10:21:26 PM »
Yes. All the claims I bought on MTO I have used a prepaid Vanilla Visa Card. Last purchase was last week.

Offline nite hawk

  • PPT Invited
  • *****
  • Posts: 492
  • Kudos: 10
Re: Any one have problems trying to stake ground??
« Reply #5 on: July 14, 2018, 08:59:33 AM »
weird how they are just now getting around to trying to put the visa debit into the system,, which so far has not worked.
Call me old fashioned, but I do NOT want a whole pile of credit cards.. I know that in the financial industry there are plenty of companies that LOVE credit cards, because it entices people to spend money on things they can never pay off, and the interest rates are crazy..
 I used to know a couple who --she told me personally they owed $75,000 in credit card debt, and I know another couple that owed $39,000 in bills.. Do not ask me how the card companies let it go so high, I don't know, but I did know the people..
 

Offline mcbain

  • PPT Invited
  • *****
  • Posts: 6076
  • Province/State: hope bc
  • Country: ca
  • Kudos: 130
Re: Any one have problems trying to stake ground??
« Reply #6 on: July 14, 2018, 07:05:44 PM »
Hi.Nite hawk that is what they feed on.If they only recover 50%  of the debt.They still made 1000.00% profit And the isurance company  pays the rest.Credit card companies never loose.Just saying .Luck Mcbain.
I started out with nothing Istill have most of it.

Offline nite hawk

  • PPT Invited
  • *****
  • Posts: 492
  • Kudos: 10
Re: Any one have problems trying to stake ground??
« Reply #7 on: July 24, 2018, 05:36:44 PM »
I finally managed to stake the ground I have been trying to pick up, had to go BACK into town, back to the government office, I even brought my own lap top in case the government computer gave me more problem. was prepared to use their wi fi if their computer mucked up like it did before, but it worked smoothly..
         I got an email the other day from MTO saying that the visa-debit now works on their site. Haven't tried it out to confirm that yet....

 


Gear Pan
Gold Rat